const regex = /1-0:1.8.2\(([0-9]{1,96}).([0-9]{1,96}).*(kWh)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('1-0:1.8.2\\(([0-9]{1,96}).([0-9]{1,96}).*(kWh)', 'gm')
const str = `/KFM5KAIFA-METER
1-3:0.2.8(42)
0-0:1.0.0(230312193138W)
0-0:96.1.1(4530303235313030303635313836373136)
1-0:1.8.1(010971.897*kWh)
1-0:1.8.2(016085.943*kWh)
1-0:2.8.1(000000.000*kWh)
1-0:2.8.2(000000.000*kWh)
0-0:96.14.0(0001)
1-0:1.7.0(00.404*kW)
1-0:2.7.0(00.000*kW)
0-0:96.7.21(00003)
0-0:96.7.9(00004)
1-0:99.97.0(5)(0-0:96.7.19)(221209092021W)(0000004031*s)(210314223749W)(0000000455*s)(210207175517W)(0000003289*s)(180331043234S)(0000000398*s)(000101000001W)(2147483647*s)
1-0:32.32.0(00000)
1-0:32.36.0(00000)
0-0:96.13.1()
0-0:96.13.0()
1-0:31.7.0(002*A)
1-0:21.7.0(00.390*kW)
1-0:22.7.0(00.000*kW)
!2284
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}