#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)1-0:1.8.2\(([0-9]{1,96}).([0-9]{1,96}).*(kWh)"
Local $sString = "/KFM5KAIFA-METER" & @CRLF & _
"" & @CRLF & _
"1-3:0.2.8(42)" & @CRLF & _
"0-0:1.0.0(230312193138W)" & @CRLF & _
"0-0:96.1.1(4530303235313030303635313836373136)" & @CRLF & _
"1-0:1.8.1(010971.897*kWh)" & @CRLF & _
"1-0:1.8.2(016085.943*kWh)" & @CRLF & _
"1-0:2.8.1(000000.000*kWh)" & @CRLF & _
"1-0:2.8.2(000000.000*kWh)" & @CRLF & _
"0-0:96.14.0(0001)" & @CRLF & _
"1-0:1.7.0(00.404*kW)" & @CRLF & _
"1-0:2.7.0(00.000*kW)" & @CRLF & _
"0-0:96.7.21(00003)" & @CRLF & _
"0-0:96.7.9(00004)" & @CRLF & _
"1-0:99.97.0(5)(0-0:96.7.19)(221209092021W)(0000004031*s)(210314223749W)(0000000455*s)(210207175517W)(0000003289*s)(180331043234S)(0000000398*s)(000101000001W)(2147483647*s)" & @CRLF & _
"1-0:32.32.0(00000)" & @CRLF & _
"1-0:32.36.0(00000)" & @CRLF & _
"0-0:96.13.1()" & @CRLF & _
"0-0:96.13.0()" & @CRLF & _
"1-0:31.7.0(002*A)" & @CRLF & _
"1-0:21.7.0(00.390*kW)" & @CRLF & _
"1-0:22.7.0(00.000*kW)" & @CRLF & _
"!2284" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")