re = /^(https?:\/\/)?([\da-z-]+\.)+([a-z]{2,6})?(\/([a-z0-9+\$_-]\.?)+)*\/?$/
str = 'http://xx.xx/x/x'
# Print the match result
str.match(re) do |match|
puts match.to_s
end