package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?:\/\/)?([\da-z-]+\.)+([a-z]{2,6})?(\/([a-z0-9+\$_-]\.?)+)*\/?$`)
var str = `http://xx.xx/x/x`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}