$re = '/^(?=.*?[A-Z])(?=.*?[a-z])(?!.*?[=?<>()\'"\/\&]).{8,20}$/m';
$str = 'Abscedsd
Ancbdj123
asjkQs23
asdfghjk
Asdfghj&
ashhgWhd=?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);