import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*?[A-Z])(?=.*?[a-z])(?!.*?[=?<>()'\"\\/\\&]).{8,20}$";
final String string = "Abscedsd\n"
+ "Ancbdj123\n"
+ "asjkQs23\n"
+ "asdfghjk\n"
+ "Asdfghj&\n"
+ "ashhgWhd=?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}