$re = '/^(?:[-+]?[1-8]?\d(?:\.\d{0,7})?|90(?:\.0{0,7})?),(?:[-+]?(?:180(?:\.0{0,7})?|(?:(?:1[0-7]\d)|(?:[1-9]?\d))(?:\.\d{0,7})?))$/';
$str = '38.303190,-77.457816';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);