import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[-+]?[1-8]?\\d(?:\\.\\d{0,7})?|90(?:\\.0{0,7})?),(?:[-+]?(?:180(?:\\.0{0,7})?|(?:(?:1[0-7]\\d)|(?:[1-9]?\\d))(?:\\.\\d{0,7})?))$";
final String string = "38.303190,-77.457816";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}