re = /^(?:lundi|mardi|mercredi|jeudi|vendredi|samedi|dimanche) [0-3]?[0-9] (?:janvier|f[eé]vrier|mars|avril|mai|juin|juillet|ao[uû]t|septembre|octobre|novembre|d[eé]cembre) [0-9]{4} [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2}$/i
str = 'Jeudi 3 avril 2014 16:23:00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end