$re = '/^(?:lundi|mardi|mercredi|jeudi|vendredi|samedi|dimanche) [0-3]?[0-9] (?:janvier|f[eé]vrier|mars|avril|mai|juin|juillet|ao[uû]t|septembre|octobre|novembre|d[eé]cembre) [0-9]{4} [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2}$/i';
$str = 'Jeudi 3 avril 2014 16:23:00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);