$re = '/\+7\s\(\d{3}\)\s\d{3}\s\d{2}\-\d{2}/m';
$str = '+7 (705) 375 24-23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);