package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+7\s\(\d{3}\)\s\d{3}\s\d{2}\-\d{2}`)
var str = `+7 (705) 375 24-23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}