$re = '/^[a-z0-9]+[\.a-z0-9]{2,}\@[a-z0-9]{2,}\.[a-z\.]{2,}$/m';
$str = 'hunganh020301@gmail.com
hung.anh020301@yahoo.com.vn
hunganh@tes.microsoft.com
hunganh 213@gmai l. com
23sneaker.store@shop.vn
h.a.anh @gmail.com
hung. anh
hung .anh
hun.2.3.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);