import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]+[\\.a-z0-9]{2,}\\@[a-z0-9]{2,}\\.[a-z\\.]{2,}$";
final String string = "hunganh020301@gmail.com\n"
+ "hung.anh020301@yahoo.com.vn\n"
+ "hunganh@tes.microsoft.com\n"
+ "hunganh 213@gmai l. com\n"
+ "23sneaker.store@shop.vn\n"
+ "h.a.anh @gmail.com\n"
+ "hung. anh\n"
+ "hung .anh\n"
+ "hun.2.3.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}