$re = '/(?:^|,)23(?:,|$)/';
$str = '23,12,13,23,45,46,123,2323,56,23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);