package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|,)23(?:,|$)`)
var str = `23,12,13,23,45,46,123,2323,56,23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}