$re = '/(\w+){2,}/';
$str = 'These are words
they killed a deer
$!@#abcd^#$%# 1234
(hi&)
Poproszę pieczonego ziemniaka UA-AA.
Poproszę miejsce na balkonie.
Poproszę piwo.
.Poproszę piwo, stek z frytkami i specjalną sałatkę szefa.
Poproszę czarno biały film.
Poproszę koc i poduszkę FAA:kol JF-109.
Poproszę. koc i poduszkę 45-minutoowe.
Poproszę .koc. * 1-2
Poproszę modelowanie włosów John-3:16.
Poproszę jajko na twardo, sok pomarańczowy i chleb.
, | | . , , ∩ ゚ ∀ ゚ . ━ ━ ━ ┗ 。 ◕ ‿ ‿ ◕ 。 . ↑ ? ? ? . ☆ , 。 ・ ・ ゚ ・ ・ ゚ ★ . ๏ ๏ ๏ ๏ ๏ ๏ , ๏ ๏ ๏ ๏ ๏ ๏ ♥ . ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ █ █ ─ █ █ ▀ █ █ █ ▀ █ █ █ ▀ █ █ █ ─ █ ─ █ █ ─ █ █ ▀ █ █ █ ─ ─ █ █ ▀ █ ─ █ ▀ █ █ ▀ █ █ █ ─ █ █ █ ▀ █ █ ▀ ▌ █ ▀ █ ▌ ▀ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ▀ ▌ █ ▀ ─ ▌ █ ─ █ ▌ ▀ █ ▌ █ ─ ─ ▌ █ ▀ ▌ █ █ ─ ▌ █ ─ ▌ █ ▌ █ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ─ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ D AY . ● ▬ ▬ ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ● . ● ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ● . ( - 。 - ) zzZZZ .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);