const regex = /(\w+){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+){2,}', 'g')
const str = `These are words
they killed a deer
\$!@#abcd^#\$%# 1234
(hi&)
Poproszę pieczonego ziemniaka UA-AA.
Poproszę miejsce na balkonie.
Poproszę piwo.
.Poproszę piwo, stek z frytkami i specjalną sałatkę szefa.
Poproszę czarno biały film.
Poproszę koc i poduszkę FAA:kol JF-109.
Poproszę. koc i poduszkę 45-minutoowe.
Poproszę .koc. * 1-2
Poproszę modelowanie włosów John-3:16.
Poproszę jajko na twardo, sok pomarańczowy i chleb.
, | | . , , ∩ ゚ ∀ ゚ . ━ ━ ━ ┗ 。 ◕ ‿ ‿ ◕ 。 . ↑ ? ? ? . ☆ , 。 ・ ・ ゚ ・ ・ ゚ ★ . ๏ ๏ ๏ ๏ ๏ ๏ , ๏ ๏ ๏ ๏ ๏ ๏ ♥ . ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ █ █ ─ █ █ ▀ █ █ █ ▀ █ █ █ ▀ █ █ █ ─ █ ─ █ █ ─ █ █ ▀ █ █ █ ─ ─ █ █ ▀ █ ─ █ ▀ █ █ ▀ █ █ █ ─ █ █ █ ▀ █ █ ▀ ▌ █ ▀ █ ▌ ▀ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ▀ ▌ █ ▀ ─ ▌ █ ─ █ ▌ ▀ █ ▌ █ ─ ─ ▌ █ ▀ ▌ █ █ ─ ▌ █ ─ ▌ █ ▌ █ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ─ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ D AY . ● ▬ ▬ ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ● . ● ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ● . ( - 。 - ) zzZZZ .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}