using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""Descr"": "".*""\s*}";
string substitution = @"""Descr"": "".*"", ""Addr"": ";
string input = @"""Descr"": ""Digital Input 0.1""
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}