// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[M|m]etalocalypse\ [s|S](\d\d)[e|E](\d\d)").unwrap();
let string = "Metalocalypse s03e01.avi
Metalocalypse s03e01.srt
Metalocalypse s03e02.avi
Metalocalypse s03e02.srt
Metalocalypse s03e03.avi
Metalocalypse s03e03.srt
Metalocalypse S03E04.avi
Metalocalypse s03e04.srt
Metalocalypse s03e05.avi
Metalocalypse s03e05.srt
Metalocalypse s03e06.avi
Metalocalypse s03e06.srt
Metalocalypse s03e07.avi
Metalocalypse s03e07.srt
Metalocalypse s03e08.avi
Metalocalypse s03e09.avi
Metalocalypse s03e09.srt
metalocalypse s03e10.avi
Metalocalypse s03e10.srt";
let substitution = "Metalocalypse.S\\1E\\2.XviD";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}