import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[M|m]etalocalypse\\ [s|S](\\d\\d)[e|E](\\d\\d)";
final String string = "Metalocalypse s03e01.avi\n"
+ "Metalocalypse s03e01.srt\n"
+ "Metalocalypse s03e02.avi\n"
+ "Metalocalypse s03e02.srt\n"
+ "Metalocalypse s03e03.avi\n"
+ "Metalocalypse s03e03.srt\n"
+ "Metalocalypse S03E04.avi\n"
+ "Metalocalypse s03e04.srt\n"
+ "Metalocalypse s03e05.avi\n"
+ "Metalocalypse s03e05.srt\n"
+ "Metalocalypse s03e06.avi\n"
+ "Metalocalypse s03e06.srt\n"
+ "Metalocalypse s03e07.avi\n"
+ "Metalocalypse s03e07.srt\n"
+ "Metalocalypse s03e08.avi\n"
+ "Metalocalypse s03e09.avi\n"
+ "Metalocalypse s03e09.srt\n"
+ "metalocalypse s03e10.avi\n"
+ "Metalocalypse s03e10.srt";
final String subst = "Metalocalypse.S\\1E\\2.XviD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}