import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9.!#$%&'*+\\/=?^_`\\{|\\}~-]+@[a-z0-9](?:[a-z0-9-]{0,64}[a-z0-9])?(?:\\.[a-z0-9](?:[a-z0-9-]{0,64}[a-z])?){1,2}$";
final String string = "bhagat.ali@gmail.com\n"
+ "bhagat.ali@gmail\n"
+ "abhagat@capitalone.com\n"
+ "bhagat.ali@gmail.co.in\n"
+ "bhagat.ali@gmail.co-in\n"
+ "bhagat.ali@gmail.co.\n"
+ "bhagat.ali@gmail.co.in.ca\n"
+ "bhagat.ali@gmail.co.in.ca.\n"
+ "bhagat.ali@gmail...com\n"
+ "ali!b@gmail.com\n"
+ "ali#b@gmail.com\n"
+ "ali$b@gmail.com\n"
+ "ali%b@gmail.com\n"
+ "ali&b@gmail.com\n"
+ "ali'b@gmail.com\n"
+ "ali***$$$b@gmail.com\n"
+ "ali+++b@gmail.com\n"
+ "ali////b@gmail.com\n"
+ "ali===Tets@gmail.com\n"
+ "ali????b@gmail.com\n"
+ "ali^^^^^^b@gmail.com\n"
+ "ali____b@gmail.com\n"
+ "ali````b@gmail.com\n"
+ "ali{{{{}}}}b@gmail.com\n"
+ "ali|||||b@gmail.com\n"
+ "ali~~~~b@gmail.com\n"
+ "ali------b@gmail.com\n"
+ "bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345678.com\n"
+ "bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345.com\n"
+ "bhagat@c.99a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}