#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-z0-9](?:[a-z0-9-]{0,64}[a-z0-9])?(?:\.[a-z0-9](?:[a-z0-9-]{0,64}[a-z])?){1,2}$"
Local $sString = "bhagat.ali@gmail.com" & @CRLF & _
"bhagat.ali@gmail" & @CRLF & _
"abhagat@capitalone.com" & @CRLF & _
"bhagat.ali@gmail.co.in" & @CRLF & _
"bhagat.ali@gmail.co-in" & @CRLF & _
"bhagat.ali@gmail.co." & @CRLF & _
"bhagat.ali@gmail.co.in.ca" & @CRLF & _
"bhagat.ali@gmail.co.in.ca." & @CRLF & _
"bhagat.ali@gmail...com" & @CRLF & _
"ali!b@gmail.com" & @CRLF & _
"ali#b@gmail.com" & @CRLF & _
"ali$b@gmail.com" & @CRLF & _
"ali%b@gmail.com" & @CRLF & _
"ali&b@gmail.com" & @CRLF & _
"ali'b@gmail.com" & @CRLF & _
"ali***$$$b@gmail.com" & @CRLF & _
"ali+++b@gmail.com" & @CRLF & _
"ali////b@gmail.com" & @CRLF & _
"ali===Tets@gmail.com" & @CRLF & _
"ali????b@gmail.com" & @CRLF & _
"ali^^^^^^b@gmail.com" & @CRLF & _
"ali____b@gmail.com" & @CRLF & _
"ali````b@gmail.com" & @CRLF & _
"ali{{{{}}}}b@gmail.com" & @CRLF & _
"ali|||||b@gmail.com" & @CRLF & _
"ali~~~~b@gmail.com" & @CRLF & _
"ali------b@gmail.com" & @CRLF & _
"bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345678.com" & @CRLF & _
"bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345.com" & @CRLF & _
"bhagat@c.99a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")