re = /(?ms)^\d+\.\s*(.*?)(?=^\d+\.|\Z)/m
str = '1. robert
smith
2. harry
3. john'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end