$re = '/(?ms)^\d+\.\s*(.*?)(?=^\d+\.|\Z)/m';
$str = '1. robert
smith
2. harry
3. john';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);