re = /(http[s]?):\/\/([^\/\s:]+)(:(\d+))?(\/[^\s#]*)?(#[^\s]*)?/m
str = 'https://abc.com/a?a=b#c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end