$re = '/(http[s]?):\/\/([^\/\s:]+)(:(\d+))?(\/[^\s#]*)?(#[^\s]*)?/m';
$str = 'https://abc.com/a?a=b#c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);