$re = '/grey (?=[a-z]+)/';
$str = 'i left my grey 123 at the grey hund
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);