using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"grey (?=[a-z]+)";
string input = @"i left my grey 123 at the grey hund
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}