import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/wtb_(.*?)[\\s](.*)?";
final String string = "/wtb_114 Адамантитовая руда\n"
+ "/wtb_111 Алюминиевая руда\n"
+ "/wtb_122 Веревка\n"
+ "/wtb_102 Ветки\n"
+ "/wtb_106 Древесный уголь\n"
+ "/wtb_108 Железная руда\n"
+ "/wtb_133 Заготовка кузнеца\n"
+ "/wtb_145 Заготовка ремесленника\n"
+ "/wtb_118 Загуститель\n"
+ "/wtb_137 Зерно\n"
+ "/wtb_120 Кожа\n"
+ "/wtb_123 Кокс\n"
+ "/wtb_136 Комбикорм\n"
+ "/wtb_104 Кость животного\n"
+ "/wtb_121 Костяная пудра\n"
+ "/wtb_166 Лезвие кинжала демона\n"
+ "/wtb_165 Лезвие кинжала охотника\n"
+ "/wtb_139 Лезвие трезубца \n"
+ "/wtb_138 Лезвие экскалибура\n"
+ "/wtb_126 Металлический лист\n"
+ "/wtb_130 Металлическое волокно\n"
+ "/wtb_112 Мифриловая руда\n"
+ "/wtb_146 Мифриловый сплав\n"
+ "/wtb_101 Нитки\n"
+ "/wtb_167 Обломок кирки шахтеров\n"
+ "/wtb_169 Обломок костолома\n"
+ "/wtb_168 Обломок молота гномов\n"
+ "/wtb_131 Обработанная кожа\n"
+ "/wtb_124 Очищенная пудра\n"
+ "/wtb_109 Плотная ткань\n"
+ "/wtb_107 Порошок\n"
+ "/wtb_141 Пыль\n"
+ "/wtb_116 Растворитель\n"
+ "/wtb_164 Рецепт браслетов демона\n"
+ "/wtb_163 Рецепт ботинок демона\n"
+ "/wtb_152 Рецепт брони паладина\n"
+ "/wtb_174 Рецепт кинжала демона\n"
+ "/wtb_173 Рецепт кинжала охотника\n"
+ "/wtb_170 Рецепт кирки шахтеров\n"
+ "/wtb_172 Рецепт костолома\n"
+ "/wtb_161 Рецепт куртки демона\n"
+ "/wtb_171 Рецепт молота гномов\n"
+ "/wtb_155 Рецепт перчаток паладина\n"
+ "/wtb_154 Рецепт сапог паладина\n"
+ "/wtb_144 Рецепт трезубца\n"
+ "/wtb_162 Рецепт шапки демона\n"
+ "/wtb_153 Рецепт шлема паладина\n"
+ "/wtb_156 Рецепт щита паладина\n"
+ "/wtb_143 Рецепт экскалибура \n"
+ "/wtb_117 Рубин\n"
+ "/wtb_115 Сапфир \n"
+ "/wtb_135 Сено\n"
+ "/wtb_132 Серебряная заготовка\n"
+ "/wtb_110 Серебряная руда\n"
+ "/wtb_125 Серебряный сплав\n"
+ "/wtb_119 Сталь\n"
+ "/wtb_127 Стальная заготовка\n"
+ "/wtb_129 Стальная нить\n"
+ "/wtb_105 Уголь\n"
+ "/wtb_175 Упаковочный материал\n"
+ "/wtb_113 Филосовский камень\n"
+ "/wtb_159 Фрагмент ботинок демона\n"
+ "/wtb_160 Фрагмент браслетов демона\n"
+ "/wtb_140 Фрагмент брони паладина\n"
+ "/wtb_157 Фрагмент куртки демона\n"
+ "/wtb_150 Фрагмент перчаток паладина\n"
+ "/wtb_149 Фрагмент сапог паладина\n"
+ "/wtb_158 Фрагмент шапки демона\n"
+ "/wtb_148 Фрагмент шлема паладина\n"
+ "/wtb_151 Фрагмент щита паладина\n"
+ "/wtb_103 Шкура животного\n"
+ "/wtb_128 Шнурок\n"
+ "/wtb_179 Хомячки\n"
+ "/wtb_178 Мясо монстров";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}