#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/wtb_(.*?)[\s](.*)?"
Local $sString = "/wtb_114 Адамантитовая руда" & @CRLF & _
"/wtb_111 Алюминиевая руда" & @CRLF & _
"/wtb_122 Веревка" & @CRLF & _
"/wtb_102 Ветки" & @CRLF & _
"/wtb_106 Древесный уголь" & @CRLF & _
"/wtb_108 Железная руда" & @CRLF & _
"/wtb_133 Заготовка кузнеца" & @CRLF & _
"/wtb_145 Заготовка ремесленника" & @CRLF & _
"/wtb_118 Загуститель" & @CRLF & _
"/wtb_137 Зерно" & @CRLF & _
"/wtb_120 Кожа" & @CRLF & _
"/wtb_123 Кокс" & @CRLF & _
"/wtb_136 Комбикорм" & @CRLF & _
"/wtb_104 Кость животного" & @CRLF & _
"/wtb_121 Костяная пудра" & @CRLF & _
"/wtb_166 Лезвие кинжала демона" & @CRLF & _
"/wtb_165 Лезвие кинжала охотника" & @CRLF & _
"/wtb_139 Лезвие трезубца " & @CRLF & _
"/wtb_138 Лезвие экскалибура" & @CRLF & _
"/wtb_126 Металлический лист" & @CRLF & _
"/wtb_130 Металлическое волокно" & @CRLF & _
"/wtb_112 Мифриловая руда" & @CRLF & _
"/wtb_146 Мифриловый сплав" & @CRLF & _
"/wtb_101 Нитки" & @CRLF & _
"/wtb_167 Обломок кирки шахтеров" & @CRLF & _
"/wtb_169 Обломок костолома" & @CRLF & _
"/wtb_168 Обломок молота гномов" & @CRLF & _
"/wtb_131 Обработанная кожа" & @CRLF & _
"/wtb_124 Очищенная пудра" & @CRLF & _
"/wtb_109 Плотная ткань" & @CRLF & _
"/wtb_107 Порошок" & @CRLF & _
"/wtb_141 Пыль" & @CRLF & _
"/wtb_116 Растворитель" & @CRLF & _
"/wtb_164 Рецепт браслетов демона" & @CRLF & _
"/wtb_163 Рецепт ботинок демона" & @CRLF & _
"/wtb_152 Рецепт брони паладина" & @CRLF & _
"/wtb_174 Рецепт кинжала демона" & @CRLF & _
"/wtb_173 Рецепт кинжала охотника" & @CRLF & _
"/wtb_170 Рецепт кирки шахтеров" & @CRLF & _
"/wtb_172 Рецепт костолома" & @CRLF & _
"/wtb_161 Рецепт куртки демона" & @CRLF & _
"/wtb_171 Рецепт молота гномов" & @CRLF & _
"/wtb_155 Рецепт перчаток паладина" & @CRLF & _
"/wtb_154 Рецепт сапог паладина" & @CRLF & _
"/wtb_144 Рецепт трезубца" & @CRLF & _
"/wtb_162 Рецепт шапки демона" & @CRLF & _
"/wtb_153 Рецепт шлема паладина" & @CRLF & _
"/wtb_156 Рецепт щита паладина" & @CRLF & _
"/wtb_143 Рецепт экскалибура " & @CRLF & _
"/wtb_117 Рубин" & @CRLF & _
"/wtb_115 Сапфир " & @CRLF & _
"/wtb_135 Сено" & @CRLF & _
"/wtb_132 Серебряная заготовка" & @CRLF & _
"/wtb_110 Серебряная руда" & @CRLF & _
"/wtb_125 Серебряный сплав" & @CRLF & _
"/wtb_119 Сталь" & @CRLF & _
"/wtb_127 Стальная заготовка" & @CRLF & _
"/wtb_129 Стальная нить" & @CRLF & _
"/wtb_105 Уголь" & @CRLF & _
"/wtb_175 Упаковочный материал" & @CRLF & _
"/wtb_113 Филосовский камень" & @CRLF & _
"/wtb_159 Фрагмент ботинок демона" & @CRLF & _
"/wtb_160 Фрагмент браслетов демона" & @CRLF & _
"/wtb_140 Фрагмент брони паладина" & @CRLF & _
"/wtb_157 Фрагмент куртки демона" & @CRLF & _
"/wtb_150 Фрагмент перчаток паладина" & @CRLF & _
"/wtb_149 Фрагмент сапог паладина" & @CRLF & _
"/wtb_158 Фрагмент шапки демона" & @CRLF & _
"/wtb_148 Фрагмент шлема паладина" & @CRLF & _
"/wtb_151 Фрагмент щита паладина" & @CRLF & _
"/wtb_103 Шкура животного" & @CRLF & _
"/wtb_128 Шнурок" & @CRLF & _
"/wtb_179 Хомячки" & @CRLF & _
"/wtb_178 Мясо монстров"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")