// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\#(?<TAG>ZKI\.NET\-PTS)[|]{2}(?<Odesilatel>.{3})[|]{2}(?<Adresat>.{3})[|]{2}(?<Predmet>.{3})[|]{2}(?<Hodnota1>.+)[\|]{2}(?<Hodnota2>.*)\#$").unwrap();
let string = "#ZKI.NET-PTS||001||S01||PRE||002||T02#";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}