re = /^\#(?<TAG>ZKI\.NET\-PTS)[|]{2}(?<Odesilatel>.{3})[|]{2}(?<Adresat>.{3})[|]{2}(?<Predmet>.{3})[|]{2}(?<Hodnota1>.+)[\|]{2}(?<Hodnota2>.*)\#$/
str = '#ZKI.NET-PTS||001||S01||PRE||002||T02#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end