package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s*?(\+|-|\*|\/)\s*(\d+)(\s*?(\+|-|\*|\/)\s*(\d+))*`)
var str = `3+2*2
23+3/32
3/2
3+5 / 2
3+5 / 32*50 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}