using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s*?(\+|-|\*|\/)\s*(\d+)(\s*?(\+|-|\*|\/)\s*(\d+))*";
string input = @"3+2*2
23+3/32
3/2
3+5 / 2
3+5 / 32*50 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}