use strict;
my $str = '# This is currently a test
{nav Home}
The statistical model estimated the probability, {tex f(x) = \\int_{-\\infty}
^\\infty \\hat f(\\xi)\\,e^{2 \\pi \\xi x} \\,d\\xi }, of capturing dolphins on a tow, {tex i}. A year effect, {tex \\lambda_{acb_{j}}} was estimated for each year, {tex j}, allowing for annual variation in the capture event rates that was unrelated to the covariates, {tex x}. The contribution of each covariate, indexed by {tex c}, was governed by a regression coefficient, {tex \\beta_c}, that was estimated by the model. The logit transform of the capture event probability was defined as the sum of the year effect, {tex \\lambda_{lam} {lam} }, and the covariates:
{tex \\lambda_{lam}{lam} }
{tex \\lambda_{lam} {lam} }
{tex \\lambda_{lam}{lam}}
katex {{{
logit(\\pi_i) = \\lambda_{j[i]} + \\sum_c \\beta_c x_{ic}.
}}}
determines the result.
# The following is more tests
katex {{{
f(x) = \\int_{-\\infty}^\\infty
\\hat f(\\xi)\\,e^{2 \\pi i \\xi x}
\\,d\\xi
}}}
katex {{{
\\begin{bmatrix}
a & b \\\\
c & a
\\end{bmatrix}
}}}
katex {{{
\\begin{bmatrix}
a & c \\\\
c & a
\\end{bmatrix}
}}}
';
my $regex = qr/{tex\b([^{}]*({[^{}]*?([^{}]|(?R))*[^{}]*?}[^{}]*)*[^{}]*)}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}