$re = '/^ +|( )(?=\1)| +$/';
$str = 'test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;