use strict;
my $str = 'test';
my $regex = qr/^ +|( )(?=\1)| +$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";