import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([01][0-9][0-9]\\.|2[0-4][0-9]\\.|[0-9][0-9]\\.|25[0-5]\\.|[0-9]\\.)([01][0-9][0-9]\\.|2[0-4][0-9]\\.|[0-9][0-9]\\.|25[0-5]\\.|[0-9]\\.)([01][0-9][0-9]\\.|2[0-4][0-9]\\.|[0-9][0-9]\\.|25[0-5]\\.|[0-9]\\.)([01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9][0-9]|[0-9])$";
final String string = "0.0.0.0\n"
+ "1.1.1.1\n"
+ "101.101.101.101\n"
+ "255.255.255.255\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}