#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([01][0-9][0-9]\.|2[0-4][0-9]\.|[0-9][0-9]\.|25[0-5]\.|[0-9]\.)([01][0-9][0-9]\.|2[0-4][0-9]\.|[0-9][0-9]\.|25[0-5]\.|[0-9]\.)([01][0-9][0-9]\.|2[0-4][0-9]\.|[0-9][0-9]\.|25[0-5]\.|[0-9]\.)([01][0-9][0-9]|2[0-4][0-9]|25[0-5]|[0-9][0-9]|[0-9])$"
Local $sString = "0.0.0.0" & @CRLF & _
"1.1.1.1" & @CRLF & _
"101.101.101.101" & @CRLF & _
"255.255.255.255" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")