re = /^.*(?=.{8,32})(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[!?@#$%^&*()\-+|=}{\/:;",'\]\[_\~<>€£¥•\\]).*$/
str = 'Querty1233#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end