$re = '/^.*(?=.{8,32})(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[!?@#$%^&*()\-+|=}{/:;",\'\]\[_\~<>€£¥•\\\\]).*$/';
$str = 'Querty1233#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);