import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(lease\\s(?P<ip>[0-9\\.]+)\\s\\{.+\\})";
final String string = "lease 10.31.31.131 {\n"
+ " starts 0 2014/08/31 14:54:11;\n"
+ " ends 0 2014/08/31 15:04:11;\n"
+ " cltt 0 2014/08/31 14:54:11;\n"
+ " binding state active;\n"
+ " next binding state free;\n"
+ " rewind binding state free;\n"
+ " hardware ethernet d0:e7:82:19:8e:ec;\n"
+ " set ddns-rev-name = \"131.31.31.10.in-addr.arpa.\";\n"
+ " set ddns-txt = \"0044522956d8e56b0f40798743a0660994\";\n"
+ " set ddns-fwd-name = \"Chromecast.example.\";\n"
+ " client-hostname \"Chromecast\";\n"
+ "}\n"
+ "lease 10.31.31.133 {\n"
+ " starts 0 2014/08/31 14:54:51;\n"
+ " ends 0 2014/08/31 15:04:51;\n"
+ " cltt 0 2014/08/31 14:54:51;\n"
+ " binding state active;\n"
+ " next binding state free;\n"
+ " rewind binding state free;\n"
+ " hardware ethernet 00:18:0a:22:2f:9f;\n"
+ " uid \"\\001\\000\\030\\012\\\"/\\237\";\n"
+ " set ddns-rev-name = \"133.31.31.10.in-addr.arpa.\";\n"
+ " set ddns-txt = \"31897a4f3a66a2733b86a7cd3b0b0b2923\";\n"
+ " set ddns-fwd-name = \"ap-1-00180a222f9f.example.\";\n"
+ " client-hostname \"ap-1-00180a222f9f\";\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}