#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(lease\s(?P<ip>[0-9\.]+)\s{.+})"
Local $sString = "lease 10.31.31.131 {" & @CRLF & _
" starts 0 2014/08/31 14:54:11;" & @CRLF & _
" ends 0 2014/08/31 15:04:11;" & @CRLF & _
" cltt 0 2014/08/31 14:54:11;" & @CRLF & _
" binding state active;" & @CRLF & _
" next binding state free;" & @CRLF & _
" rewind binding state free;" & @CRLF & _
" hardware ethernet d0:e7:82:19:8e:ec;" & @CRLF & _
" set ddns-rev-name = "131.31.31.10.in-addr.arpa.";" & @CRLF & _
" set ddns-txt = "0044522956d8e56b0f40798743a0660994";" & @CRLF & _
" set ddns-fwd-name = "Chromecast.example.";" & @CRLF & _
" client-hostname "Chromecast";" & @CRLF & _
"}" & @CRLF & _
"lease 10.31.31.133 {" & @CRLF & _
" starts 0 2014/08/31 14:54:51;" & @CRLF & _
" ends 0 2014/08/31 15:04:51;" & @CRLF & _
" cltt 0 2014/08/31 14:54:51;" & @CRLF & _
" binding state active;" & @CRLF & _
" next binding state free;" & @CRLF & _
" rewind binding state free;" & @CRLF & _
" hardware ethernet 00:18:0a:22:2f:9f;" & @CRLF & _
" uid "\001\000\030\012\"/\237";" & @CRLF & _
" set ddns-rev-name = "133.31.31.10.in-addr.arpa.";" & @CRLF & _
" set ddns-txt = "31897a4f3a66a2733b86a7cd3b0b0b2923";" & @CRLF & _
" set ddns-fwd-name = "ap-1-00180a222f9f.example.";" & @CRLF & _
" client-hostname "ap-1-00180a222f9f";" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")