re = /Content-Type:\s+([\w\/+]+)/i
str = 'Content-type: image/jpeg sadfasdf'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result