use strict;
my $str = 'Content-type: image/jpeg sadfasdf';
my $regex = qr@Content-Type:\s+([\w/+]+)@ip;
my $subst = '';
my $result = $str =~ s@$regex@$subst@r;
print "The result of the substitution is' $result\n";