$re = '/(<li.*<input type="checkbox" >)(.*\n*.*)(</li>)/m';
$str = '<li class="task-list-item"><input type="checkbox" > Der Unit-Test <code>contextMenuReplacesText</code> wurde auskommentiert um die ausführung zu verhindern. Dieser Test funktioniert in meiner Umgebung nicht wie erwachtet. (Tastatur Layout?, Aktivierte Sprache des Betriebsystems?)
Datei: <code>X:\\pdfsam\\pdfsam-fx\\src\\test\\java\\org\\pdfsam\\ui\\prefix\\PrefixFieldTest.java</code></li>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);