const regex = new RegExp('(<li.*<input type="checkbox" >)(.*\\n*.*)(</li>)', 'm')
const str = `<li class="task-list-item"><input type="checkbox" > Der Unit-Test <code>contextMenuReplacesText</code> wurde auskommentiert um die ausführung zu verhindern. Dieser Test funktioniert in meiner Umgebung nicht wie erwachtet. (Tastatur Layout?, Aktivierte Sprache des Betriebsystems?)
Datei: <code>X:\\pdfsam\\pdfsam-fx\\src\\test\\java\\org\\pdfsam\\ui\\prefix\\PrefixFieldTest.java</code></li>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}