$re = '/^[A-Za-z0-9]{1,4}\:[A-Za-z0-9]{1,4}\:/m';
$str = '2001:4860:4860::8888';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);