package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]{1,4}\:[A-Za-z0-9]{1,4}\:`)
var str = `2001:4860:4860::8888`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}